rfc-9806

Updates to SIP-Based Media Recording (SIPREC) to Correct Metadata Media Type

D. Mongrain
date2025-06 streamIETF areaart wgsipcore statusPROPOSED STANDARD pages4 canonicalhttps://www.rfc-editor.org/rfc/rfc9806 doi10.17487/RFC9806
The SIP-based Media Recording (SIPREC) protocol is defined by both "Session Initiation Protocol (SIP) Recording Metadata" (RFC 7865) and "Session Recording Protocol" (RFC 7866). Unfortunately, both RFCs contradict each other regarding how recording metadata is to be labeled. In addition, neither RFC registered the new media type. This document updates RFC 7866 to align with RFC 7865 when labeling recording metadata and also registers the media type.

updates

Extracted elements (7)

design-rationale §1

RFC 7865 was identified as normative for SIPREC metadata (it defines the metadata format), so when the two RFCs contradicted each other on media type labeling, RFC 7866 was updated to align with RFC 7865 rather than vice versa.

sip, realtime

errata §1

RFC 9806 resolves Erratum ID 7987 against RFC 7866, which reported that RFC 7866 used 'application/rs-metadata' while RFC 7865 (the normative metadata specification) used 'application/rs-metadata+xml'. Every instance of 'application/rs-metadata' in RFC 7866 is replaced with 'application/rs-metadata+xml'.

sip, realtime

interoperability-note §4.1

RFC 7866 previously specified 'application/rs-metadata', which has been replaced by 'application/rs-metadata+xml' in RFC 9806. Implementations that used the old media type label from RFC 7866 must be updated to use 'application/rs-metadata+xml'.

sip, realtime

normative-requirement §2 MUST

Each instance of 'application/rs-metadata' in RFC 7866 MUST be replaced with 'application/rs-metadata+xml' to align with the media type defined in RFC 7865.

sip, realtime

protocol-element §4.1

The media type 'application/rs-metadata+xml' is the correct label for SIPREC recording metadata content, as defined in RFC 7865. It is used by Session Recording Clients (SRCs) and Session Recording Servers (SRSs) when identifying metadata in XML form.

sip, realtime, json

registry §4.1

IANA registration of the 'application/rs-metadata+xml' media type. Type: application, subtype: rs-metadata+xml, no required or optional parameters, encoding follows 'application/xml' per RFC 7303, intended usage COMMON, change controller IETF.

registry, sip, realtime

security-consideration §3

The updates in RFC 9806 only clarify inconsistencies in media type labeling and do not introduce any new security considerations beyond those already listed in RFC 7866.

security, sip