rfc-9104

Distribution of Traffic Engineering Extended Administrative Groups Using the Border Gateway Protocol - Link State (BGP-LS)

J. Tantsura, Z. Wang, Q. Wu, K. Talaulikar
date2021-08 streamIETF areartg wgidr statusPROPOSED STANDARD pages7 canonicalhttps://www.rfc-editor.org/rfc/rfc9104 doi10.17487/RFC9104
Administrative groups are link attributes used for traffic engineering. This document defines an extension to the Border Gateway Protocol - Link State (BGP-LS) for advertisement of extended administrative groups (EAGs).

Extracted elements (8)

design-rationale §1

The original administrative groups were defined as a fixed-length 32-bit bitmask. As networks grew and more use cases emerged, the 32-bit length was found to be constraining, motivating the introduction of extended administrative groups (EAGs) in RFC 7308.

bgp, routing, mpls

interoperability-note §1

The EAG TLV is not a replacement for the existing Administrative Group (color) TLV 1088; as specified in RFC 7308, both values can coexist in a BGP-LS advertisement. The behavior of BGP-LS consumers receiving both TLVs is out of scope for this document.

bgp, routing

normative-requirement §2 MUST

The Length field of the Extended Administrative Group TLV MUST be a multiple of 4. If the length is not a multiple of 4, the TLV MUST be considered malformed.

bgp, routing

protocol-element §2

The Extended Administrative Group TLV (Type 1173) is a new BGP-LS Link Attribute TLV that encodes extended administrative groups (EAGs) for links. The Value field contains one or more 32-bit bitmasks indicating which administrative groups are enabled on the link.

bgp, routing, mpls

registry §3

IANA assigned code point 1173 from the 'BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs' registry for the Extended Administrative Group TLV, with a corresponding IS-IS TLV/Sub-TLV reference of 22/14.

registry, bgp, routing

security-consideration §5

It is assumed that IGP instances originating the EAG TLV will support required security mechanisms for OSPF (RFC 7474, RFC 4552, RFC 7166) and IS-IS (RFC 5304) to prevent security issues when propagating the Sub-TLVs into BGP-LS.

security, bgp, routing

security-consideration §5

The procedures and protocol extensions defined in this document do not affect the BGP security model. Any syntactic error in the new Attribute TLV would result in the BGP-LS Attribute being discarded per RFC 7752. The advertisement of EAG link attribute information presents no significant additional risk beyond existing link attribute information already supported in RFC 7752.

security, bgp, routing

wire-format §2

The EAG TLV has a 16-bit Type field (value 1173), a 16-bit Length field (variable, in octets), and a variable-length Value field consisting of one or more 32-bit bitmasks. The Length MUST be a multiple of 4 octets.

bgp, routing