Signaling Entropy Label Capability and Entropy Readable Label Depth Using OSPF
Extracted elements (17)
Although ELC is a property of the node, it is advantageous to associate and advertise ELC with a prefix in multi-area and multi-domain networks, where routers may not know the identity or capabilities of prefix originators in remote areas or domains.
The exact mechanism used to exchange ELC between protocol instances on an ASBR (when redistributing prefixes between OSPF instances or from other protocols) is outside the scope of this document.
A router MUST NOT announce ELC unless all of its interfaces are capable of processing ELs.
ELC signaling MUST be preserved when an OSPF ABR distributes information between areas; the ABR MUST originate an OSPFv2 Extended Prefix Opaque LSA including the received ELC setting.
For OSPFv3, the ELC Flag in the AS-External-LSA, NSSA-LSA, or External-Prefix TLV generated by an ASBR MUST be the same as the value of the ELC Flag associated with the prefix in the source domain.
For OSPFv3, the ELC Flag in the Inter-Area-Prefix-LSA or Inter-Area-Prefix TLV generated by an ABR MUST be the same as the value of the ELC Flag associated with the prefix in the source area.
If a router has multiple interfaces with different capabilities of reading the maximum label stack depth, the router MUST advertise the smallest value found across all of its interfaces for ERLD.
If the router supports ELs on all of its interfaces, it SHOULD advertise the ELC with every local host prefix it advertises in OSPF.
When an OSPF ASBR redistributes a prefix from another instance of OSPF or another protocol, it SHOULD preserve the ELC signaling and originate an Extended Prefix Opaque LSA including the ELC setting. The flooding scope of the Extended Prefix Opaque LSA MUST match the flooding scope of the LSA the ASBR originates as a result of redistribution.
When the ERLD-MSD type is received in the OSPFv2 or OSPFv3 Link MSD sub-TLV, it MUST be ignored.
ELC and ERLD can be signaled in BGP-LS: ELC is advertised using the Prefix Attribute Flags TLV (RFC 9085), and ERLD-MSD is advertised using the Node MSD TLV (RFC 8814).
ERLD is advertised in a Node Maximum SID Depth (MSD) TLV using the ERLD-MSD type defined in RFC 9088. Absence of ERLD-MSD advertisements indicates only that the node does not support advertisement of this capability.
The E-Flag (ELC Flag), bit 0x40, is defined in the OSPFv3 PrefixOptions field. When set by the advertising router, it indicates the prefix originator is capable of processing Entropy Labels.
The E-Flag (ELC Flag), value 0x20, is defined in the OSPFv2 Extended Prefix TLV Flags field. When set by the advertising router, it indicates the prefix originator is capable of processing Entropy Labels.
IANA allocated bit 0x40 in the 'OSPFv3 Prefix Options (8 bits)' registry for the E-Flag (ELC Flag) as defined in this document.
IANA allocated flag 0x20 in the 'OSPFv2 Extended Prefix TLV Flags' registry for the E-Flag (ELC Flag) as defined in this document.
Incorrectly setting the E-Flag during origination, propagation, or redistribution may lead to poor or no load-balancing of MPLS traffic, or to MPLS traffic being discarded on the egress node. Incorrectly setting the ERLD value may similarly lead to poor or no load-balancing.