rfc-8093

Deprecation of BGP Path Attribute Values 30, 31, 129, 241, 242, and 243

J. Snijders
date2017-02 streamIETF areartg wgidr statusPROPOSED STANDARD pages3 canonicalhttps://www.rfc-editor.org/rfc/rfc8093 doi10.17487/RFC8093
This document requests IANA to mark BGP path attribute values 30, 31, 129, 241, 242, and 243 as "Deprecated".

Extracted elements (5)

design-rationale §1

As a workaround to the Large Communities/value-30 collision, a new Early IANA Allocation was requested for the BGP Large Communities attribute, rather than requiring all deployed implementations to update. The squatting of values 30, 31, 129, 241, 242, and 243 was confirmed by the involved vendors or through source code review.

bgp, registry

design-rationale §1

Certain BGP Path Attribute values were used in deployed BGP implementations without being assigned by IANA, a practice called "squatting". Unregistered usage of BGP Path Attribute values can lead to deployment problems for new technologies that later receive formal IANA assignment of those same values.

bgp, registry

interoperability-note §1

When BGP Large Communities (RFC 8092) was initially assigned attribute value 30 by IANA, a widely deployed BGP-4 implementation already used that value with a different data structure. That implementation applied a "Treat-as-withdraw" (RFC 7606) strategy to routes containing a valid Large Community attribute, causing early adopters of Large Communities to be unreachable from parts of the Internet.

bgp

registry §2

IANA has marked BGP Path Attribute values 30, 31, 129, 241, 242, and 243 as "Deprecated" in the "BGP Path Attributes" subregistry under the "Border Gateway Protocol (BGP) Parameters" registry. The "Deprecated" marking means "use is not recommended".

bgp, registry

security-consideration §3

There are no meaningful security consequences arising from this registry update marking BGP path attribute values 30, 31, 129, 241, 242, and 243 as "Deprecated".

bgp, security