rfc-7335

IPv4 Service Continuity Prefix

C. Byrne
date2014-08 streamIETF areaops wgv6ops statusPROPOSED STANDARD pages4 canonicalhttps://www.rfc-editor.org/rfc/rfc7335 doi10.17487/RFC7335
Dual-Stack Lite (DS-Lite), defined in RFC 6333, directs IANA to reserve 192.0.0.0/29 for the Basic Bridging BroadBand (B4) element. Per this memo, IANA has generalized that reservation to include other cases where a non-routed IPv4 interface must be numbered as part of an IPv6 transition solution.

updates

Extracted elements (8)

design-rationale §4

Rather than reserving a separate prefix for every IPv6 transition solution (such as 464XLAT) that needs a non-routed IPv4 prefix, RFC 7335 generalizes the existing DS-Lite reservation (192.0.0.0/29) to cover all such cases, avoiding address space fragmentation.

ip, v6ops

design-rationale §4

The 192.0.0.0/29 prefix is suitable for reuse across transition solutions because, as established in RFC 6333 for DS-Lite, this subnet is only present internally (e.g., between B4 and AFTR) and never emits packets from this prefix on the wire.

ip, v6ops

interoperability-note §3

464XLAT (RFC 6877) requires the CLAT element—when embedded in a host such as a smartphone or CPE—to have an IPv4 address configured for the host network stack and for applications to bind IPv4 sockets, driving the same need for a reserved non-routed IPv4 prefix as DS-Lite.

ip, v6ops

interoperability-note §1

The generalization of 192.0.0.0/29 from DS-Lite-specific to the broader IPv4 Service Continuity Prefix does not impact existing DS-Lite deployments using this address block.

ip, v6ops

normative-requirement §4 MUST NOT

A host MUST NOT enable two active IPv4 continuity solutions simultaneously in a way that would cause a node to have overlapping 192.0.0.0/29 address space.

ip, v6ops

protocol-element §1

The 192.0.0.0/29 prefix is designated as the IPv4 Service Continuity Prefix, reserved for any system that requires IPv4 addresses for backward compatibility with IPv4 communications in an IPv6-only network but does not emit IPv4 packets 'on the wire'.

ip, v6ops

registry §6

IANA updated the IPv4 Special-Purpose Address Registry entry for 192.0.0.0/29, renaming it from 'DS-Lite' (RFC 6333) to 'IPv4 Service Continuity Prefix' (RFC 7335), with attributes: Source=True, Destination=True, Forwardable=True, Global=False, Reserved-by-Protocol=False.

ip, v6ops, registry

security-consideration §5

RFC 7335 introduces no new security considerations beyond those described in RFC 6333 (DS-Lite) and RFC 6877 (464XLAT).

security, ip, v6ops