rfc-6473

vCard KIND:application

P. Saint-Andre
date2011-12 streamIETF areaapp wgvcarddav statusPROPOSED STANDARD pages5 canonicalhttps://www.rfc-editor.org/rfc/rfc6473 doi10.17487/RFC6473
This document defines a value of "application" for the vCard KIND property so that vCards can be used to represent software applications. [STANDARDS-TRACK]

Extracted elements (10)

design-rationale §2

A more fine-grained taxonomy of applications (e.g., KIND "application" with subtypes like "server" or "IM server") was explicitly considered but ruled out of scope for this document.

design-rationale §1

The VCARDDAV Working Group originally considered but removed a generic "thing" KIND value for any physical entity, machine, or software application; this document instead defines the narrower "application" value, deferring generic "thing" to a possible future extension.

interoperability-note §2

An "application" KIND is functionally equivalent to the 'applicationProcess' object class used in LDAP (RFC 4519) as derived from the OSI model (X.521, X.200), providing a formal reference for the concept.

ldap

normative-requirement §2 MAY

When a property represents information about an individual associated with the application (e.g., an individual service administrator), inclusion of "work" and "home" TYPE values can be appropriate.

normative-requirement §2 SHOULD NOT

When a vCard property represents some aspect of the application itself, it makes no sense to include "work" or "home" values of the TYPE parameter, since software applications do not have workplaces or personal lives.

protocol-element §2

A non-exhaustive list of base vCard properties applicable to application vCards includes: ADR, EMAIL, FN, GEO, IMPP, KEY, KIND, LANG, LOGO, NOTE, ORG, PHOTO, REV, SOURCE, TEL, TZ, and URL.

protocol-element §2

Properties in an application vCard may apply to one of three categories: the application itself (FN, URL, ADR, GEO, TZ), an organization making the application available (LOGO), or a person maintaining the application (TEL, EMAIL, IMPP).

protocol-element §2

The KIND property value "application" indicates that the vCard represents a software application such as a server, an online service (e.g., a chat room), or an automated software bot.

yang

registry §4

IANA has added "application" to the registry of property values for vCard4 (per RFC 6350 Section 10.2.6). The value indicates the entity is a software application; it is conformant with the KIND property.

registry

security-consideration §5

Use of vCards to represent software applications is not envisioned to introduce security considerations beyond those specified for vCards in general as described in RFC 6350.

security