rfc-6286

Autonomous-System-Wide Unique BGP Identifier for BGP-4

E. Chen, J. Yuan
date2011-06 streamIETF areartg wgidr statusPROPOSED STANDARD pages4 canonicalhttps://www.rfc-editor.org/rfc/rfc6286 doi10.17487/RFC6286 errataview
To accommodate situations where the current requirements for the BGP Identifier are not met, this document relaxes the definition of the BGP Identifier to be a 4-octet, unsigned, non-zero integer and relaxes the "uniqueness" requirement so that only Autonomous-System-wide (AS-wide) uniqueness of the BGP Identifiers is required. These revisions to the base BGP specification do not introduce any backward compatibility issues. This document updates RFC 4271. [STANDARDS-TRACK]

updates

Extracted elements (10)

design-rationale §1

The BGP Identifier definition is relaxed from a valid IPv4 host address to any 4-octet non-zero integer to accommodate situations such as IPv6-only networks where assigning a valid IPv4 address to every BGP speaker may not be feasible. Only AS-wide uniqueness is required rather than global uniqueness.

bgp, routing

design-rationale §3

The BGP Identifier is also used in the AGGREGATOR attribute (combined with AS number to identify the aggregating speaker), in route reflection within an AS (only internal neighbor BGP Identifiers may be propagated in reflection attributes), and in route selection. None of these usages are broken by the relaxed definition.

bgp, routing

design-rationale §3

The uniqueness requirement is relaxed to AS-wide scope rather than global scope because BGP Identifiers are only operationally significant within an AS for route reflection, aggregation attribution, and collision resolution. The revisions are backward compatible with existing BGP Identifier allocations based on RFC 4271.

bgp, routing

interoperability-note §3

A BGP speaker supporting the AS-wide Unique BGP Identifier cannot share a BGP Identifier with an external neighbor until the remote BGP speaker is upgraded with software that supports these revisions. No backward compatibility issues are introduced with current usage.

bgp, routing

interoperability-note §3

In a BGP Confederation, the whole confederation is treated as one AS for the purpose of AS-wide Unique BGP Identifier support. A BGP Identifier allocated per RFC 4271 (as a valid IPv4 address) remains conformant with the relaxed definition.

bgp, routing

normative-requirement §2.2 MUST

If the BGP Identifier field of the OPEN message is zero, or if it is the same as the BGP Identifier of the local BGP speaker and the message is from an internal peer, the Error Subcode MUST be set to 'Bad BGP Identifier'.

bgp, routing

normative-requirement §2.1 MUST

The BGP Identifier MUST be a 4-octet, unsigned, non-zero integer that should be unique within an AS. The value is determined on startup and is the same for every local interface and every BGP peer.

bgp, routing

normative-requirement §2.3 MUST

When connection collision occurs between external peers with identical BGP Identifiers, the connection initiated by the BGP speaker with the larger AS number is preserved. This covers 4-octet AS numbers per RFC 4893.

bgp, routing

protocol-element §2.1

The BGP Identifier under this specification is a 4-octet, unsigned, non-zero integer required to be unique only within an AS (AS-wide uniqueness), rather than globally unique as previously required. It is set at startup and is consistent across all interfaces and peers.

bgp, routing

security-consideration §4

This extension to BGP does not introduce new security considerations. BGP security considerations remain as discussed in RFC 4271.

bgp, security, routing