Reserved IPv6 Interface Identifiers
Extracted elements (11)
An IANA registry was chosen over adding normative references to each specification that reserves an IID because the normative reference approach does not scale well (too many specs to update) and would create downward reference problems when a reserving document has lower maturity than a prohibited document.
Future assignments from the reserved IID registry are discouraged because implementations might predate a specific assignment and thus not be cognizant of the reserved nature of the identifier, leading to unexpected conflicts.
Implementations of RFC 2590, 3315, 3972, 4489, 4862, 4941, 4982, and 5072 need to be aware of the reserved interface identifier ranges when allocating new addresses; future revisions of those RFCs should clarify or amend their text accordingly.
The unspecified address :: (all-zeros IID) and ::/0 (default route indicator) do not conflict with the reserved identifiers defined here, since those reserved identifiers specifically target the 64-bit prefix stateless address autoconfiguration use case.
Future assignments to the reserved IPv6 interface identifiers registry are to be made through Standards Action as defined in RFC5226. Assignments consist of a single interface identifier or a range of interface identifiers.
Reserved IPv6 interface identifiers MUST NOT be used for autonomous autoconfiguration or for managed address configuration. A node using such an identifier may receive requests it is not authorized to receive.
IPv6 unicast address interface identifiers (for addresses not starting with binary 000) are required to be 64 bits long and constructed in Modified EUI-64 format per RFC4291. This document applies only to IIDs formed in that modified EUI-64 format.
The interface identifier 0000:0000:0000:0000 is reserved as the Subnet-Router Anycast address per RFC4291 and must not be used for autoconfigured or managed addresses.
The reserved interface identifier range FDFF:FFFF:FFFF:FF80 through FDFF:FFFF:FFFF:FFFF is reserved for subnet anycast addresses per RFC2526, including the Mobile IPv6 home agent anycast address at FDFF:FFFF:FFFF:FFFF.
This document creates an IANA registry for reserved IPv6 interface identifiers. Initial entries are: 0000:0000:0000:0000 (Subnet-Router Anycast, RFC4291) and FDFF:FFFF:FFFF:FF80 through FDFF:FFFF:FFFF:FFFF (Reserved Subnet Anycast Addresses, RFC2526).
By utilizing a reserved interface identifier, an IPv6 node might receive requests it is not authorized to receive. Information that creates or updates a registration in the reserved IID registry must be authenticated and authorized by IANA per RFC5226.