rfc-5003

Attachment Individual Identifier (AII) Types for Aggregation

C. Metz, L. Martini, F. Balus, J. Sugimoto
date2007-09 streamIETF areartg wgpwe3 statusPROPOSED STANDARD pages7 canonicalhttps://www.rfc-editor.org/rfc/rfc5003 doi10.17487/RFC5003 errataview
The signaling protocols used to establish point-to-point pseudowires include type-length-value (TLV) fields that identify pseudowire endpoints called attachment individual identifiers (AIIs). This document defines AII structures in the form of new AII TLV fields that support AII aggregation for improved scalability and Virtual Private Network (VPN) auto-discovery. It is envisioned that this would be useful in large inter-domain virtual private wire service networks where pseudowires are established between selected local and remote provider edge (PE) nodes based on customer need. [STANDARDS-TRACK]

Extracted elements (13)

design-rationale §3.2

AII Type 2 permits varying levels of AII summarization, reducing the scaling burden on AII distribution mechanisms (e.g., MP-BGP) and PE memory. Without aggregation, individual AII values could number in the tens of thousands or more and would need to be distributed or configured on all local PEs.

mpls, routing

design-rationale §1

Globally unique AII values (enabled by embedding the provider's ASN as Global ID) facilitate PW management and security in large inter-AS and inter-provider environments, eliminating the need for AII NAT boxes during signaling and enabling source-validity checks on AII distribution.

mpls, security

design-rationale §3.2

The use of the provider's ASN as a Global ID in AII Type 2 is purely for global uniqueness of the AII value and has no relationship to the use of ASNs in routing protocols such as BGP.

mpls, routing

interoperability-note §1

AII Type 2 is defined within the framework of the GID FEC element (type 129) from RFC 4447, which also defines AGI semantics. The SAI is <AGI, SAII> and TAI is <AGI, TAII>; the SAI and TAI can be distinct values.

mpls

interoperability-note §1

PWE3 signaling messages (LDP-based) always include a fully qualified AII value regardless of aggregation. Aggregation reduces distribution and storage overhead but does not change the wire representation in PW signaling.

mpls

normative-requirement §3.2 MUST

If the Global ID is derived from a 2-octet AS number, the two high-order octets of the 4-octet Global ID field MUST be set to zero.

mpls

protocol-element §3.1

AII Type 1 is a fixed-length 32-bit value allocated by IANA for use with provisioning models. This value is unique on the local PE only, not globally unique.

mpls

protocol-element §3.2

The 32-bit Prefix field in AII Type 2 is assigned by the provider or can be automatically derived from the PE's /32 IPv4 loopback address. It does not need to have any association with the IPv4 address space used in the provider's IGP or BGP.

mpls, ip

protocol-element §3.2

The Attachment Circuit (AC) ID is a fixed-length 4-octet field used to further refine identification of an attachment circuit on the PE. It identifies individual attachment circuits sharing a common prefix.

mpls

protocol-element §3.2

The Global ID field in AII Type 2 is a 4-octet field containing a value unique to the provider, typically derived from the provider's 2-octet or 4-octet Autonomous System Number (ASN). Use of a globally unique ASN ensures global uniqueness of the AII.

mpls, routing

registry §4

IANA allocated value 0x02 from the 'Attachment Individual Identifier (AII) Type' registry defined in RFC 4446 for AII Type 2 as defined in this document.

registry, mpls

security-consideration §5

AII values appearing in AII distribution protocols and PW signaling protocols are subject to authentication schemes such as MD5 if desired. The use of Global ID values based on ASNs in inter-provider cases can enable source-validation checking to verify that AII values originated from a legitimate source.

security, mpls

wire-format §3.2

AII Type 2 TLV encodes a 1-octet type (0x02), 1-octet length (12), a 4-octet Global ID, a 4-octet Prefix, and a 4-octet AC ID, for a total value field of 12 octets. The structure supports globally unique AII values through the combination of these three fields.

mpls