rfc-4558

Node-ID Based Resource Reservation Protocol (RSVP) Hello: A Clarification Statement

Z. Ali, R. Rahman, D. Prairie, D. Papadimitriou
date2006-06 streamIETF areartg wgccamp statusPROPOSED STANDARD pages7 canonicalhttps://www.rfc-editor.org/rfc/rfc4558 doi10.17487/RFC4558
Use of Node-ID based Resource Reservation Protocol (RSVP) Hello messages is implied in a number of cases, e.g., when data and control planes are separated, when TE links are unnumbered. Furthermore, when link level failure detection is performed by some means other than exchanging RSVP Hello messages, use of a Node-ID based Hello session is optimal for detecting signaling adjacency failure for Resource reSerVation Protocol-Traffic Engineering (RSVP-TE). Nonetheless, this implied behavior is unclear, and this document formalizes use of the Node-ID based RSVP Hello session in some scenarios. The procedure described in this document applies to both Multi-Protocol Label Switching (MPLS) and Generalized MPLS (GMPLS) capable nodes. [STANDARDS-TRACK]

Extracted elements (9)

design-rationale §1

In GMPLS networks, control plane and data plane are separated, meaning RSVP Hello messages are terminated at control channel endpoints (identified by Node-ID) rather than on data bearer link interfaces. This separation necessitates Node-ID based Hello sessions rather than interface-bound Hello sessions.

routing, mpls

design-rationale §1

When link failure detection is performed by means other than RSVP Hello messages (e.g., BFD), Node-ID based Hello sessions are optimal for detecting signaling adjacency failures when there is more than one link between a pair of nodes, as interface-bound Hellos would conflate link and adjacency failures.

routing, mpls

interoperability-note §3

Node-ID based Hello sessions can co-exist with interface-bound Hello sessions when it is desirable to distinguish between signaling adjacency and link failures, or when a pair of nodes share both numbered and unnumbered TE links.

routing, mpls

interoperability-note §4

The procedure is backward compatible with both RFC 3209 and RFC 3473. It uses the IPv4/IPv6 source address as local node_id and IPv4/IPv6 destination address as remote node_id, without modifying TTL/Hop Limit setting and processing or Hello Processing for State Recovery defined in RFC 3473 Section 9.3.

routing, mpls

normative-requirement §3 MUST

When a node receives a Hello packet where the destination IP address is its local Node-ID as advertised in the IGP-TE topology, the node MUST use its Node-ID in replying to the Hello message. Nodes MUST ensure that the Node-IDs used in RSVP Hello messages are those derived/contained in the IGP-TE topology.

routing, mpls

normative-requirement §3 MUST

When link failure detection is performed by means other than exchanging RSVP Hello messages, or if all interfaces between a pair of nodes are unnumbered, or in a GMPLS network with data and control plane separation, a node MUST run Node-ID based Hello sessions for detection of signaling adjacency failure for RSVP-TE.

routing, mpls

protocol-element §3

A Node-ID based Hello session is established by using local and remote Node-IDs in the source and destination IP address fields of Hello packets, respectively. A node can only run one Node-ID based RSVP Hello session per IGP instance (i.e., per Node-ID pair) with its neighbor.

routing, mpls

protocol-element §2

Node-ID is defined as the TE Router ID advertised in the Router Address TLV for OSPF and Traffic Engineering Router ID TLV for ISIS. For IPv6, Node-ID refers to Router_IPv6_Address for OSPFv3 and IPv6 TE Router_ID for IS-IS.

routing, mpls

security-consideration §5

This document does not modify or extend the RSVP Hello messages exchange between immediate RSVP neighbors, so it does not introduce new security considerations. RSVP message security is described in RFC 2747, which provides Hello message integrity and authentication of the Node-ID ownership.

security, routing, mpls