rfc-2111

Content-ID and Message-ID Uniform Resource Locators

E. Levinson
date1997-03 streamIETF areaapp wgmhtml statusPROPOSED STANDARD pages5 canonicalhttps://www.rfc-editor.org/rfc/rfc2111 doi10.17487/RFC2111
The Uniform Resource Locator (URL) schemes, "cid:" and "mid:" allow references to messages and the body parts of messages. For example, within a single multipart message, one HTML body part might include embedded references to other parts of the same message. [STANDARDS-TRACK]

obsoleted by

Extracted elements (12)

design-rationale §2

Conforming implementations may, but are not required to, exploit the global uniqueness of content-ids to resolve a 'cid' URL to any body part in the message store rather than limiting lookup to the current message.

email

design-rationale §2

The 'mid' URL long form (message-id/content-id) was designed to supply the context needed to support interoperability with message store systems that do not index body parts independently of their containing message, even though Content-IDs are required to be globally unique.

email

interoperability-note §2

RFC 1738 reserves the 'mid' and 'cid' URL schemes for Message-ID and Content-ID respectively; this RFC defines the syntax for those previously reserved but undefined schemes.

email

normative-requirement §2 REQUIRED

A conforming implementation is required to support the 'mid' URL long form (message-id/content-id) to supply the context needed for systems that do not index body parts independently of their containing message.

email

normative-requirement §2 REQUIRED

Both message-id and content-id are required to be globally unique: no two different messages will ever have the same Message-ID addr-spec, and no different body parts will ever have the same Content-ID addr-spec.

email

normative-requirement §2 REQUIRED

When a single message contains several body parts with the same Content-ID (e.g., within multipart/alternate), conforming implementations are required to use the rules of the containing MIME entity to select the body part to which the Content-ID refers.

email

protocol-element §2

A 'cid' URL is converted to a Content-ID message header by removing the 'cid:' prefix, converting %hh hex-escaped characters to ASCII equivalents, and enclosing the result in angle brackets. For example, 'cid:foo4%[email protected]' becomes 'Content-ID: <foo4%[email protected]>'.

email

protocol-element §2

A 'mid' URL is converted to a Message-ID or Message-ID/Content-ID pair by the same process: strip the 'mid:' prefix, decode %hh escapes, and enclose with angle brackets. The slash separator between message-id and content-id remains after decoding.

email

protocol-element §2

The 'cid:' URL scheme identifies a specific MIME body part by its Content-ID. Its use is generally limited to references to other body parts within the same message as the referring body part.

email, http

protocol-element §2

The 'mid:' URL scheme identifies an email message by its Message-ID, and optionally a specific body part within that message by appending a content-id: 'mid:' message-id [ '/' content-id ]. A 'mid' URL with only a message-id refers to the entire message.

email

security-consideration §3

The cid and mid URL values disclose no more about the originator's environment than the corresponding Message-ID and Content-ID header values. Where confidentiality is a concern, originators using mid and cid URLs must take the same precautions already required for Message-ID and Content-ID in email.

security, email, privacy

wire-format §2

Both cid and mid URLs are based on url-addr-spec, which is a URL-encoded RFC 822 addr-spec. Characters not allowed in a URL (including '/', which is reserved within the 'mid' scheme) must be hex-encoded using the %hh escape mechanism.

email