draft-zhuang-idr-flowspec-extension-for-ncm

BGP Flow Specification Extensions for Network Congestion Management

groupnone stateactive pages15 rev00 expires2026-09-20 canonicalhttps://datatracker.ietf.org/doc/draft-zhuang-idr-flowspec-extension-for-ncm/
BGP Flow Specification (FlowSpec) [RFC8955] and [RFC8956] has been proposed to distribute traffic filter policy (traffic filters and actions) via BGP [RFC4271]. Multiple applications have used BGP FlowSpec to distribute traffic filter policy. These applications include the following: mitigation of denial of service (DoS), enabling traffic filtering in BGP/MPLS VPNs, centralized traffic control of router firewall functions, and SFC traffic insertion. Due to its powerful extensibility, FlowSpec can be easily used for network congestion management. This document describes how to use BGP FlowSpec to implement network congestion management.