draft-ietf-radext-deprecating-radius
Deprecating Insecure Practices in RADIUS
RADIUS crypto-agility was first mandated as future work by RFC 6421.
The outcome of that work was the publication of RADIUS over TLS (RFC
6614) and RADIUS over DTLS (RFC 7360) as experimental documents.
Those transport protocols have been in wide-spread use for many years
in a wide range of networks, and have recently been standardized in
[I-D.ietf-radext-radiusdtls-bis]. TLS has proven to be a useful
replacment for UDP (RFC 2865) and TCP (RFC 6613) transports. With
that knowledge, the continued use of insecure transports for RADIUS
has serious and negative implications for privacy and security.
The publication of the "BlastRADIUS" exploit has also shown that
RADIUS security needs to be updated. It is no longer acceptable for
RADIUS to rely on MD5 for security. It is no longer acceptable to
send device or location information in clear text across the wider
Internet. This document therefore deprecates many insecure practices
in RADIUS, and mandates support for secure TLS-based transport
layers. Related security issues with RADIUS are discussed, and
recommendations are made for practices which increase both security
and privacy.