draft-ietf-lsr-ospf-yang-augmentation-v1

OSPF YANG Model Augmentations for Additional Features - Release 1

streamIETF grouplsr stateactive intendedProposed Standard pages74 rev18 expires2026-07-12 canonicalhttps://datatracker.ietf.org/doc/draft-ietf-lsr-ospf-yang-augmentation-v1/
This document defines YANG data modules that augment the IETF OSPF YANG model to support various OSPF extensions and features, including Traffic Engineering Extensions to OSPF Version 3 as defined in RFC 5329, OSPF Two-Part Metric as defined in RFC 8042, OSPF Graceful Link Shutdown as defined in RFC 8379, OSPF Link-Local Signaling (LLS) Extensions for Local Interface ID Advertisement as defined in RFC 8510, OSPF MSD as defined in RFC 8476, OSPF Application-Specific Link Attributes as defined in RFC 9492, and OSPF Flexible Algorithm as defined in RFC 9350.